PDA

View Full Version : SetupBuilder 5 Developer Edition (RC1) #1101


NewsArchive
04-13-2005, 01:42 AM
[Sunday, April 10, 2005 5:45 PM]

SB5 Developer Edition (RC1) build #1101 is released.

Please click "Check for Updates..." from within your SB5 IDE to update to
#1101.

----------------------------------------------------------------------------

- SetupBuilder 5.0 Build 1101 #Release Candidate 1# (April 10, 2005)

Features/Improvements/Fixes/Workaround/Changes/Notes:

FEATURE : Add "Registry Import Wizard" to import .REG Registry files
IMPROVEMENT: Add Ctrl-E hotkey to go to the Script Editor
IMPROVEMENT: Add Ctrl-P and Ctrl-N hotkeys to go the previous or next IDE
view
IMPROVEMENT: Add "Read License Agreement File from Absolute Path" checkbox
to the "License Agreement" dialog
IMPROVEMENT: Add "Read Readme File from Absolute Path" checkbox to the
"Readme" dialog
IMPROVEMENT: Compiler detects missing previous version patch objects now
IMPROVEMENT: Registry screen improvements. Enter key in left pane opens
the Rename field. Insert/Delete keys in left pane activate
Add/Remove. Enter key in right pane opens the "Edit Registry
Data" window. Insert key creates a new value (opens the
popup menu that the mouse activates to select which data type
to create). Delete key removes a value.
IMPROVEMENT: Add "Setup Types" button to the Toolbar
IMPROVEMENT: "Send File(s) to Recycle Bin" function can include the
wildcards "*" and "?"
IMPROVEMENT: Add "Default Font" option to select the font which your setup
will use when it runs on a target machine
IMPROVEMENT: Add a first draft of the .chm online help system
IMPROVEMENT: Add [EXENAME] compiler variable
IMPROVEMENT: Several IDE enhancements
FIX : "Get INI Value" script item did not allow variables in the INI
Section and INI Item
FIX : When changing include scripts, the compiler did not trigger a
recompile when doing a Test, or Run
FIX : Possible "smart string resource compiler" problem
FIX : Possible "Select String Resource" problem when using more than
one language
FIX : Possible "Browse For Folder..." dialog problem when working on
an include script
FIX : Possible "License Agreement" radio button problem
FIX : Possible Auto Update Scanning Wizard problem when using the
"Generate Binary Patch" option
FIX : Setup Type [Advanced] dialog does not display the "&" character
any longer
FIX : Possible problem when writing binary data to the Registry
FIX : Possible problem when reading binary data from the Registry
FIX : Minor IDE fixes
CHANGE : "Set Installer Flag" script item supports the $SB_ALLUSERSFLAG$
and $RESTARTFLAG$ flags
CHANGE : On Windows NT/2000/XP/2003 and if user has Administrator
rights,
the application will be (by default) installed for all users
that share the computer
CHANGE : %_SB_SETUPTYPEID% variable returns the selected Setup Type Name
now instead of the selected Setup Type ID
CHANGE : Replace Clarion LIST controls with a native Windows equivalent
in the "Set Variable" script item
CHANGE : Minor Run VBScript Interface modifications
CHANGE : Minor "Run VBScript Demo.sb5" script modifications
CHANGE : iDeploy compiler clears \Web folder before generating web
cluster files
CHANGE : The Open dialog opens in the directory that the currently open
script resides

----------------------------------------------------------------------------

--
Friedrich Linder
CEO, Lindersoft
www.lindersoft.com
1.954.252.3910

NewsArchive
04-13-2005, 01:42 AM
[Sunday, April 10, 2005 6:42 PM]

Hi Friedrich,

Happy SUNDAY where the chm file is out! smiles....
Download and all updated versions are of course ferfect
the blue and white chm help file is here too!
BRAVO!

Enjoy your daughter now...<g>

JP

NewsArchive
04-13-2005, 01:42 AM
[Monday, April 11, 2005 5:04 PM]

Thank you Jean-Pierre :)

Friedrich

NewsArchive
04-13-2005, 01:43 AM
[Sunday, April 10, 2005 8:38 PM]

Smooth download (W2K, cable).
The Dynamic Help item pulls up real live documentation!!
The Reference Manual help item doesn't seem to do anything.
Looking forward to checking out the additions.

In the area of what-have-you-done-for-us-lately, Friedrich... as you're
using H&M, could you also compile the documentation as a PDF that we could
download? I'm vegetarian, but I love to kill trees ;)

Also, just a bit of FYI arcane trivia - in the documentation under System
Requirements you mention "the System partition (where the Windows\System
folder resides.)"....
In Microsoft speak, the partition containing System32 is the "boot
partition". The partition (normally C:\ drive) containing boot.ini is the
"system partition". (I am NOT making this up.....see attached screen shot)

Thanks for a great product!

Jane

NewsArchive
04-13-2005, 01:43 AM
[Monday, April 11, 2005 5:13 PM]

Hi Jane,

Thank you!!!!

The PDF manual will be available later this week. There is still some work
to do on the documentation.

BTW, you are right. I have changed the system requirements text now:

---

For optimal performance of SetupBuilder development environment, we
recommend:

1. Microsoft Windows 2000 or greater Operating System.
2. 150 MB of available hard disk space.
3. At least 128 MB of memory is the minimal requirement. For optimal
performance we recommend 512 MB.
4. A processor that can offer power comparable with a Pentium III 500Mhz is
the minimal requirement. For best performance we recommend a processor
that can offer power comparable to a Pentium III 1.0 Ghz.
5. Internet Explorer 5.0 or later.
6. Screen resolution of at least 1024x768 with 32-bit color.

Installers built with SetupBuilder run on all 32-bit versions of Windows.

---

Thanks again,
Friedrich

--
Friedrich Linder
CEO, Lindersoft
www.lindersoft.com
1.954.252.3910

NewsArchive
04-13-2005, 01:44 AM
[Monday, April 11, 2005 7:58 AM]

Friedrich,

Tried to Update (twice) using the "Check for Updates" for SB5 Dev #1078 to #
1101 -
(Cable modem download, however slower Road Runner Lite version - W2K PRO)

Both times ended with this error - Source file not found
www.lindersoft.com/sb5/sb51101_dev.0049. Verify that the file exists and
that you can access it.

since the install did not complete, I let it rollback to previous.

I downloaded the full version sb5_1101_Dev.exe 6,614,456, and it uninstalled
previous version and upgraded to Dev #1101 correctly, and I must say, that
..chm looks VERY nice! <g>


David

NewsArchive
04-13-2005, 01:44 AM
[Monday, April 11, 2005 8:16 AM]

Hi David,

> Tried to Update (twice) using the "Check for Updates" for SB5 Dev #1078 to
> #
> 1101 -
> (Cable modem download, however slower Road Runner Lite version - W2K PRO)
>
> Both times ended with this error - Source file not found
> www.lindersoft.com/sb5/sb51101_dev.0049. Verify that the file exists and
> that you can access it.

Hmm, I installed 1078 but cannot reproduce this :-( It upgraded to 1101
without any problem. Do you remember if there was another error message
after the above?

> since the install did not complete, I let it rollback to previous.
>
> I downloaded the full version sb5_1101_Dev.exe 6,614,456, and it
> uninstalled
> previous version and upgraded to Dev #1101 correctly, and I must say, that
> ..chm looks VERY nice! <g>

Thank you :)

Friedrich

NewsArchive
04-13-2005, 01:44 AM
[Monday, April 11, 2005 9:25 AM]

Friedrich,

No, only that single error message, then I got the window that said the
install did not complete, do you want to rollback? Even with the slower
download rate of Road Runner Lite, the patch install process appeared to go
smoothly until the source file not found error.

David

NewsArchive
04-13-2005, 01:46 AM
[Monday, April 11, 2005 3:07 PM]

Hi Friedrich,

>Hmm, I installed 1078 but cannot reproduce this :-( It upgraded to 1101

I have 1078 and I'll by attempting to update tonight (your time, my
time;) - on dialup;) I will give you details on how it goes.

Best regards,

Arnór Baldvinsson
Icetips Software
San Antonio, Texas, USA

NewsArchive
04-13-2005, 01:47 AM
[Wednesday, April 13, 2005 9:45 AM]

Hi Arnór,

Did your 1078 version update to the latest version?

Thank you!

Friedrich

--
Friedrich Linder
CEO, Lindersoft
www.lindersoft.com
1.954.252.3910

NewsArchive
04-13-2005, 01:47 AM
[Monday, April 11, 2005 4:42 PM]

Upgrade from 1078 to 1101 went smoothly, however, I am unable to access any
of the "Help" from within the application. When I click on help or press the
F1 key from within the IDE the mouse changes to an hour glass briefly as if
it is loading and then nothing.

Accessing the help from the start menu works just fine.

Win XP SP2

Lee

NewsArchive
04-13-2005, 01:48 AM
[Monday, April 11, 2005 4:48 PM]

Lee,

Simon Burrows reported the same. We are using the C61 templates to provide
"Help" so I cannot do anything here.

Please reboot your machine and try it again (this should fix this).

--
Friedrich Linder
CEO, Lindersoft
www.lindersoft.com
1.954.252.3910

NewsArchive
04-13-2005, 01:48 AM
[Monday, April 11, 2005 6:14 PM]

Restarting the IDE fixed that issue. Thanks.

--
Russ Eggen
www.radfusion.com

NewsArchive
04-13-2005, 01:49 AM
[Monday, April 11, 2005 7:24 PM]

Friedrich,

My experience was the same as the others. A re-boot was not required. Just
exit the IDE and execute it again fixed the problem. Whatever it was.

Lee

NewsArchive
04-13-2005, 01:49 AM
[Monday, April 11, 2005 4:56 PM]

Hi Lee

I had the same. Unload SB5 and Reload. If not, reboot. Works then.

Cheers
Simon

NewsArchive
04-13-2005, 01:50 AM
[Monday, April 11, 2005 6:13 PM]

Ditto, I get the hour glass, then nothing. Also, where is the distribution
wizard? Must be hiding in plain sight <bg>

--
Russ Eggen
www.radfusion.com

NewsArchive
04-13-2005, 01:50 AM
[Monday, April 11, 2005 6:21 PM]

Under the "Generator Settings" there is now a new Media Type and Media Size
item (disabled at the moment). The compiler should be smart enough to
automatically split images (we are still testing this feature).

Friedrich

NewsArchive
04-13-2005, 01:51 AM
[Monday, April 11, 2005 9:26 PM]

OK.

One thing I found a bit confusing was the zip archive dialog. I assume the
first entry is the name of the zip file you wish to place the install EXE
in. The file dialog expects an existing zip file. Really could not go past
this point as I don't understand how to create a new zip. And wouldn't you
know it, but that is one of the few dialogs not covered in the help. Why
me? <bg>

--
Russ Eggen
www.radfusion.com

NewsArchive
04-13-2005, 01:51 AM
[Tuesday, April 12, 2005 12:17 PM]

:)

Topic added to the help file and (Zip Archive Name) file dialog bug fixed.

Friedrich

--
Friedrich Linder
CEO, Lindersoft
www.lindersoft.com
1.954.252.3910

NewsArchive
04-13-2005, 01:51 AM
[Tuesday, April 12, 2005 4:13 PM]

Thank you!

--
Russ Eggen
www.radfusion.com

NewsArchive
04-13-2005, 01:52 AM
[Monday, April 11, 2005 8:44 AM]

And the PRO version?

Sim

NewsArchive
04-13-2005, 01:52 AM
[Monday, April 11, 2005 5:19 PM]

Hi Sim,

We'll try to release SB5 Professional RC1 tomorrow.

--
Friedrich Linder
CEO, Lindersoft
www.lindersoft.com
1.954.252.3910

NewsArchive
04-14-2005, 09:21 AM
[Thursday, April 14, 2005 5:11 PM]

Follow up on this report:

Upgraded from 1101 to 1103. All went well, however, the same thing happened
with the "Help". After the install completed, the IDE was automatically
launched from the installer. Help was unavailable.

Exit the IDE and re-start it. Help is available.

Lee

NewsArchive
04-14-2005, 09:23 AM
[Thursday, April 14, 2005 5:23 PM]

Thank you Lee. Unfortunately, I cannot do anything here. We are using the
latest C61 templates to provide "Help" support.

Friedrich

NewsArchive
04-19-2005, 09:33 AM
[Monday, April 18, 2005 11:37 PM]

Tried version #1103 and all works. One "minor problem -- when the
installer is actually installing, there is a message,
"Str_ProgramAction_13" instead of some text (I think). I'm not sure if
this is a bug, but I can't get rid of it.

Paul

NewsArchive
04-19-2005, 09:33 AM
[Tuesday, April 19, 2005 2:59 AM]

IIRC, you need to click "Update String Resources" on the "Project" menu...
There was a post from Friedrich on February 1. He had attached a new
language file. Mine now says "Copying new files"

If you click the View menu in the IDE, then Setup Project Details, then Text
and Messages, then click the Misc Progress item under the Progress folder,
you'll see the definitions in the right pane.

Jane

NewsArchive
04-19-2005, 09:34 AM
[Tuesday, April 19, 2005 4:15 PM]

Thanks Jane, that did it.

Paul

NewsArchive
04-19-2005, 09:34 AM
[Tuesday, April 19, 2005 2:00 AM]

hi friedrich,

ive misplaced my activation key. can you plz resend?...

regards,
-pratik

NewsArchive
04-19-2005, 09:34 AM
[Tuesday, April 19, 2005 5:52 AM]

On 18 Apr 2005 20:00:18 -0400, Pratik Patel wrote:

> ive misplaced my activation key. can you plz resend?...

Its on your activation keyring:)
--

Mark

NewsArchive
04-23-2005, 07:44 AM
[Tuesday, April 19, 2005 6:20 PM]

Hi Pratik,

See private email.

--
Friedrich Linder
CEO, Lindersoft
www.lindersoft.com
1.954.252.3910