PDA

View Full Version : SetupBuilder 5 Developer Edition (RC4 - #1154)


NewsArchive
06-02-2005, 10:53 AM
SB5 Developer Edition (RC4) build #1154 is released.

Please click "Check for Updates..." from within your SB5 IDE to update to
#1154.

----------------------------------------------------------------------------


- SetupBuilder 5.0 Build 1154 #Release Candidate 4# (June 02, 2005)

Features/Improvements/Fixes/Workaround/Changes/Notes:

IMPROVEMENT: Files and Folder screen - add a (Patch) or (Multi-Patch)
"visual
indicator" to the lower right list to show whether a file is
patched
IMPROVEMENT: Add a German language module (special thanks to Roland Schärli)
FIX : SetupBuilder IDE crashed with an "Internal error 06 : CTLMAIN -
invalid handle" GPF on Windows 9x and ME machines
FIX : Possible Text Resource problem
FIX : Possible Search Script problem
FIX : Possible Auto Update Scan problems
FIX : Files and Folder screen - pressing the Add button with nothing
selected in the top pane crashed the IDE
FIX : Possible sub-feature "out-of-sync" problem (compiler generated
incorrect code)
FIX : Possible focus problem in the Script Editor
FIX : Possible create text resource problem
CHANGE : Minor modifications to the internal "open script" function
CHANGE : When adding a new text resource, the property dialog
immediately opens
CHANGE : Minor IDE modifications

----------------------------------------------------------------------------

--
Friedrich Linder
CEO, Lindersoft
www.lindersoft.com
1.954.252.3910

sphair
06-06-2005, 03:34 AM
One minor issue with 1154:

I upgraded from an earlier version, and main script updated fine. I have one include, which it didn't upgrade the MINVER pragma in.

When I compile my project now, I get:

FixitUninstall.sbi(13): error GEN1015: Script requires a more recent compiler. Required: 5.0.1120

My included source says:
#pragma MINVER = 5.0.1120

The main source was upgraded nicely to:
#pragma MINVER = 5.0.1151

So, it seems you have two bugs:
1. Include scripts don't upgrade
2. The error message doesn't display the required version, but the version in the sourcecode. Shouldn't the message have been:
FixitUninstall.sbi(13): error GEN1015: Script requires a more recent compiler. Required: 5.0.1151 ?

Also, a feature request would be able to copy from the Compiler Output!

Best regards,
Kenneth

linder
06-06-2005, 10:40 AM
Kenneth,

Bugs fixed and feature added.

Thanks,