Reply to Thread

Post a reply to the thread: Installer Behavior on Load Error

Your Message

Click here to log in

What's the name of our main installation product (in uppercase letters), directly followed by the current year?

 

You may choose an icon for your message from this list

Additional Options

  • Will turn www.example.com into [URL]http://www.example.com[/URL].

Topic Review (Newest First)

  • 12-28-2018, 09:39 AM
    st09

    Re: Installer Behavior on Load Error

    Friedrich,

    The behavior in latest build (6106) looks good.

    Thanks!
    Seth
  • 12-23-2018, 06:10 AM
    linder

    Re: Installer Behavior on Load Error

    Seth,

    you should have received a build 6100 update notification (via e-mail and web update).

    Friedrich
  • 12-21-2018, 01:10 PM
    st09

    Re: Installer Behavior on Load Error

    Friedrich,

    Is there supposed to be an attachment? I see none.

    Seth
  • 12-21-2018, 09:54 AM
    linder

    Re: Installer Behavior on Load Error

    Seth,

    too late <g>. The new build 6100 was already code-complete. Could you please test the stub behaviour? If it does not work as expected, I'll send you a new private build.

    Friedrich
  • 12-20-2018, 08:30 AM
    st09

    Re: Installer Behavior on Load Error

    Hello Friedrich,

    Thank you for addressing this. Yes, you may send me a demo executable. Do you have patches to the libraries as well?

    Regards,
    Seth
  • 12-15-2018, 08:23 AM
    linder

    Re: Installer Behavior on Load Error

    Hello,

    we have fixed it now. Am I allowed to send you a small demo setup.exe?

    Thanks,
    Friedrich
  • 12-10-2018, 03:43 PM
    linder

    Re: Installer Behavior on Load Error

    I have checked the source code and it seems to me that some error codes always "reset" to 0. Item in review! Thank you for bringing this to our attention.

    Friedrich
  • 12-10-2018, 03:30 PM
    linder

    Re: Installer Behavior on Load Error

    Hello,

    is this with the /S command line switch? We are busy testing our new remote deploy feature and we need a completely silent installer, even if there is a "loader" error. In our tests (with the /S switch set) it never displayed a dialog.

    I have opened a ticked and we'll try to simulate a locked temp directory scenario.

    Friedrich
  • 12-10-2018, 10:01 AM
    st09

    Installer Behavior on Load Error

    In the release notes for SetupBuilder 2018 Version 10 Build 6074, the following is listed:


    CHANGE: Installer: When SetupBuilder failed to extract its temporary system files to the temp directory (either because of an anti-virus or permissions issues), it reported the error with a popup, but did not have a return code of non-zero to indicate an error. For automated installations there were no way to know that it encountered an error. It returns a non-zero exit code in this case now.

    However, this does not appear to be the behavior. If the temp directory is not accessible, the following dialog appears, and the return code from the installer is zero.

    Attachment 4826

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •