+ Reply to Thread
Results 1 to 9 of 9

Thread: PreRequisites issue

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Andrew Guest

    Default PreRequisites issue

    Hello.

    I try setup PreRequisites for .NET 4.0. I checked .NET 4.0 Redistibutable package and download this package.
    Next I compile installer.
    But when I run this installer on the machine without .NET 4.0 it tells me 4.0 is not installed but does not give me any option to install it. (It just will not let me continue with the setup).

    What's wrong?
    I expect it should offer install .net 4.0 on the machine without 4.0.

    Thanks, Andrew

  2. #2
    Join Date
    Mar 2004
    Posts
    4,241

    Default Re: PreRequisites issue

    Andrew,

    Where is this "NET 4.0 is not installed" message coming from? Did you add it (e.g. in the script)?

    Or did you accidentally mark the ".NET Framework is Installed" System Software Requirements that checks if .NET4 (or whetever) is installed and if this is not the case, aborts the install?

    "The Requirements Visualizer allows you to specify certain machine environments that your application requires in order to run properly. If these system requirements are not met, the installation will exit. Because your application cannot be installed on systems that do not meet your hardware or software requirements, you may want to set those requirements liberally."

    Friedrich
    Attached Images Attached Images  

  3. #3
    Andrew Guest

    Default Re: PreRequisites issue

    Quote Originally Posted by linder View Post

    Friedrich
    Thanks. I unmarked ".NET Framework is Installed" It helps, but not at all.
    Now after setup and run exe I got message
    "To run this application you first install one of the following of the .NET Framework: 4.0/
    Contact your application publisher...."

    MSI doens't ask me install .net 4.0

    By the way when I run this setup it said that it require 64(MB). It's size with 4.0 bootstrapper. But when it has been installed summary size of setup is 10Mb without any 4.0 bootstrapper. may be it doesn't been downloaded through web-setup?

  4. #4
    Join Date
    Mar 2004
    Posts
    4,241

    Default Re: PreRequisites issue

    Andrew,

    Sorry, but I fear I can't follow

    What displays "To run this application you first install one of the following of the .NET Framework: 4.0/Contact your application publisher...."? Your application or the installer?

    And what does "MSI doens't ask me install .net 4.0" mean?

    Sorry for my confusion.

    You only have to mark the .NET4 checkbox in SetupBuilder and the compiler will package the .NET4 redistributable into your setup.exe. See attached screenshot.

    BTW, you can check the %DOTNET4_INSTALLIT% variable after the .NET4 installation process to find out if it succeeded.

    To see what the compiler did, you can check the compiler window and the compiler .htm report.

    Does this help?

    Friedrich
    Attached Images Attached Images     

  5. #5
    Andrew Guest

    Default Re: PreRequisites issue

    Quote Originally Posted by linder View Post
    Andrew,

    Sorry, but I fear I can't follow

    What displays "To run this application you first install one of the following of the .NET Framework: 4.0/Contact your application publisher...."? Your application or the installer?

    And what does "MSI doens't ask me install .net 4.0" mean?

    Sorry for my confusion.

    You only have to mark the .NET4 checkbox in SetupBuilder and the compiler will package the .NET4 redistributable into your setup.exe. See attached screenshot.

    BTW, you can check the %DOTNET4_INSTALLIT% variable after the .NET4 installation process to find out if it succeeded.

    To see what the compiler did, you can check the compiler window and the compiler .htm report.

    Does this help?

    Friedrich
    Thanks

    I have first,second,third screen.
    Forth - without Message Box command.
    Erorr message I got after install, when I try run my exe
    I expect, that if I Haven't .NET 4.0 sb offers me to install it.
    I think, sb package .net to my setup.exe. (I see this big file at installation files) but by some reason it isn't download from my web deploy folder when I run setup..

  6. #6
    Join Date
    Mar 2004
    Posts
    4,241

    Default Re: PreRequisites issue

    Hello,

    But what is the value of %DOTNET4_INSTALLIT% and %DOTNET4_RETURNCODE% (see previous screenshot) in your case? The values of these variables will give you more information what happened and why. For example, if the operating system is Windows XP SP3 then %DOTNET4_INSTALLIT% is -1000 because the Microsoft .NET4 Framework requires XP SP3.

    Does this help?

    Friedrich
    Attached Images Attached Images  

  7. #7
    Andrew Guest

    Default Re: PreRequisites issue

    Quote Originally Posted by linder View Post
    Hello,

    But what is the value of %DOTNET4_INSTALLIT% and %DOTNET4_RETURNCODE% (see previous screenshot) in your case? The values of these variables will give you more information what happened and why. For example, if the operating system is Windows XP SP3 then %DOTNET4_INSTALLIT% is -1000 because the Microsoft .NET4 Framework requires XP SP3.

    Does this help?

    Friedrich
    Thanks, it works!!

    PS sorry for late answer

  8. #8
    Join Date
    Mar 2004
    Posts
    4,241

    Default Re: PreRequisites issue

    Perfect Thanks for the update!

    Friedrich

  9. #9
    Join Date
    Mar 2004
    Posts
    4,241

    Default Re: PreRequisites issue

    By the way, if you are interested, you can send your .sb7 to support [at] lindersoft [dot] com and we'll review your project for you.

    Friedrich

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •