Please excuse the length of the explanation.
I've changed my setup to include a large data file. (Client request) To distribute, I'm adding Web Install. Web update has always worked well.
Website has the usual structure where the public directory is where the root of the website exists and the download directories are below that.
So http://mywebsite.com/software/client/pgs_setup.exe will download the setup exe
This also requires a login - user: password
That all works fine. And when I set up Web Installation, these settings work perfectly.
Host: mywebsite.com, Port: 80, Host Directory: software/client, Host User: user, Host Password: password
As a test this is just right. WebInstall works and the software gets installed.

BUT Client requires a secure connection so I want to use the generic SSL that is included in my hosting package. Very easy. I enable the certificate and a directory is added to my site named secure.
This directory is accessible through a different address - https://secure1.webexchange.com/mywebsite.com
From there, the /secure directory is the root. I then create software/client directories under /secure and place the all the installation files in there.
I can now download the installer from secure URL - https://secure1.webexchange.com/mywe.../pgs_setup.exe Hooray!
BUT, The installing crashes when it tries to get the file segments from the web. Error 5060.
I've dealt with this before and I searched through the forum for other hints; I even contacted my host to see if they had something set oddly.

Here is how I have it setup -
Host: secure1.webexchange.com, Port: 443, Host Directory: mywebsite.com/software/client, Host User: user, Host Password: password
I've tried IIS Server Image checkbox both on and off
and .bin File Extension on and off. - because I've had that issue before.
Still Error 5060.

Is there something that I should ask my host?
Do you see ANYTHING I've got wrong?
Is there a scripting change needed to handle the new secure URL?

Thanks for any suggestions,
Chris C