GŁnter,

I think your installer needs administrator execution level privileges. Try
to unmark the "Per-User" checkbox and recompile your .msi.

Friedrich