+ Reply to Thread
Results 1 to 4 of 4

Thread: REG: Add "Code Folding" in editor / Weird issue

  1. #1
    Join Date
    Apr 2015
    Location
    Merced, CA, Unitedd States
    Posts
    111

    Post REG: Add "Code Folding" in editor / Weird issue

    Hello:

    So, I just thought up a wonderful idea, add "code folding" to the script editor thus for those quite large installs (like the one I'm working on right now), you can expand and collapse not only the in-built sections (such as "create folders" and "modify system") but you could create a group of actions (e.g. several file install operaations for a single feature, a very large conditional, etc.) thus if you need to go to some action way out in the weeds (like line 25,201) you're not sitting there killing your finger on the scroll wheel or other such as much (e.g. if you can fold in sections above or below your target line it makes for less scrolling and hunting)

    And the weird issue I'm experiencing is two fold (pardon the pun) really:
    1. When large patches of code are deleted and new things are put in their place I've wound up with install files statements right in the middle of my if/then blocks
    2. in an effort to move some of the displaced lines of code (e.g. a define feature, install files, or some others) I get a dialog that some of the items cannot be moved/copied (e.g. select the displaced code then CTRL+X (cut) then CTRL+V (paste where I want it) does not work thus result in using the up/down buttons at the bottom of the script editor.

    Does anyone have any thoughts on these issues?

    Best:
    CF

  2. #2
    Join Date
    Mar 2004
    Posts
    4,241

    Default Re: REG: Add "Code Folding" in editor / Weird issue

    CF,

    not directly related to these issues... but would it be possible for you to simply use include and exclude wildcards (e.g. *.exe, *.dll, or even *.*) here? This would make the script so much cleaner.

    Friedrich

  3. #3
    Join Date
    Apr 2015
    Location
    Merced, CA, Unitedd States
    Posts
    111

    Default Re: REG: Add "Code Folding" in editor / Weird issue

    Quote Originally Posted by linder View Post
    CF,

    not directly related to these issues... but would it be possible for you to simply use include and exclude wildcards (e.g. *.exe, *.dll, or even *.*) here? This would make the script so much cleaner.

    Friedrich
    Hi:

    I started in the visualizer mode and am putting the final touches on it in script editor. Since per feature has a lot of sub-folders and files the “recursive add” along with with seeing things by features helps me mentally keep track of it. Can such a wildcard statement recurse all the way down a folder tree? If so, ive got to try this next time.

  4. #4
    Join Date
    Apr 2015
    Location
    Merced, CA, Unitedd States
    Posts
    111

    Default Re: REG: Add "Code Folding" in editor / Weird issue

    Update:

    Well my 33k+ line script monster has been tamed and ultimately re-done using the *.* trick linder provided . I’m compiling now to give it a run. That compile will take 4+ hours on my current SB Machine. I noticed an interesting thing while I was trying to get this working. I have all the files for each of my components in a folder called “ files to install to app directory”. When pointing the install files action at the component level folder which does need to be included for my application to work, I noticed that the folder itself is not included and I must use the visualizer to create its replica and then load the *.* into that pre-staged folder. Other than that, seems to be working like a charm I’ll report back in the morning as soon as I know more.

    What my development paths look like: C:\Users\vmware\Desktop\ProjectRoot\Files To Install To App Dir\Component\*.*

    What the end-user paths should look like: %_SB_INSTALLDIR%\Component\*.*

    Note that the component directory *does* need to be there.

    I have also noticed that by creating the appropriately pre-staged folders using a create folder action that I am not able to assign them for components and wound up having to do and if feature statement.

    Update: yes, the install Files feature does recurse. However, one thing I’d love to see added is an option to install empty directories that are in my folder structure anyway. Just a thought

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •